Foreward: An ALU is an Autonomous Learning Unit, you can read this post to learn more about them.
Paste the following configuration into R2:
interface Loopback64
ip address 24.0.64.2 255.255.255.0
interface Loopback65
ip address 24.0.65.2 255.255.255.0
interface Loopback66
ip address 24.0.66.2 255.255.255.0
interface Loopback67
ip address 24.0.67.2 255.255.255.0
R2 is in AS 200, R3 is in AS 300, R4 is in AS 400. R2 and R3 should peer via their respective Serial interfaces. R2 and R4 should peer via their FastEthernet interfaces. Advertise all four Loopback subnets via BGP. Advertise a summary address on R2 to R3 and R4. Do not advertise any specific prefixes to R3. R4 should see the summary address and the 24.0.65.0/24 prefix. Your "show ip bgp" output on R2 should match the following output:
Highlight below for the solution:
Solution:
R2:
router bgp 200
network 24.0.64.0 mask 255.255.255.0
network 24.0.65.0 mask 255.255.255.0
network 24.0.66.0 mask 255.255.255.0
network 24.0.67.0 mask 255.255.255.0
aggregate-address 24.0.64.0 255.255.252.0 summary-only
neighbor 1.1.23.3 remote-as 300
neighbor 1.1.124.4 remote-as 400
neighbor 1.1.124.4 unsuppress-map UNSUPPRESS
no auto-summary
ip prefix-list BGP65 seq 5 permit 24.0.65.0/24
route-map UNSUPPRESS permit 10
match ip address prefix-list BGP65
Confirmation:
R2#show ip bgp ne 1.1.23.3 advertised-routes | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/22 0.0.0.0 32768 I
R3#show ip bgp | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/22 1.1.23.2 0 0 200 i
R2#show ip bgp neighbor 1.1.124.4 advertised-routes | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/22 0.0.0.0 32768 i
s> 24.0.65.0/24 0.0.0.0 0 32768 i
R4#show ip bgp | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/22 1.1.124.2 0 0 200 i
*> 24.0.65.0/24 1.1.124.2 0 0 200 i
Explanation:
As explained in my previous post, unlike most other routing protocols, BGP does not suppress more specific prefixes when summarizing. The "summary-only" keyword on the "aggregate-address" command is used to suppress all prefixes. If you are required to leak certain prefixes to a specific neighbor, the "unsuppress-map" option on a neighbor statement will allow a specific prefix that was suppressed by the "summary-only" keyword on the "aggregate-address" command to be advertised to that neighbor.
It is helpful to remember that you can set BGP options from within the "unsuppress-map" route-map in addition to matching prefixes. Therefore, if you are required to set parameters such as AS Prepending, communities, or MED values on a specific unsuppressed prefix, the easiest method of doing that is in the route-map used for the "unsuppress-map" command.
DocCD items to reference:
show ip bgp neighbors [advertised-routes]
No comments:
Post a Comment