Paste the following configuration into R2:
interface Loopback64
ip address 24.0.64.2 255.255.255.0
interface Loopback65
ip address 24.0.65.2 255.255.255.0
interface Loopback66
ip address 24.0.66.2 255.255.255.0
interface Loopback67
ip address 24.0.67.2 255.255.255.0
R2 is in AS 200, R3 is in AS 300. R2 and R3 should peer via their respective Serial interfaces. Advertise all four Loopback subnets via BGP. Advertise a summary address to R3. Do not advertise the 24.0.65.0/24 subnet to R3. Your "show ip bgp" output on R2 should match the following output:
R2#show ip bgp | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/24 0.0.0.0 0 32768 i
*> 24.0.64.0/22 0.0.0.0 32768 i
s> 24.0.65.0/24 0.0.0.0 0 32768 i
*> 24.0.66.0/24 0.0.0.0 0 32768 i
*> 24.0.67.0/24 0.0.0.0 0 32768 i
Highlight below for the solution:
Solution:
R2:
router bgp 200
no synchronization
bgp log-neighbor-changes
network 24.0.64.0 mask 255.255.255.0
network 24.0.65.0 mask 255.255.255.0
network 24.0.66.0 mask 255.255.255.0
network 24.0.67.0 mask 255.255.255.0
aggregate-address 24.0.64.0 255.255.240.0 suppress-map SUPPRESS
neighbor 1.1.23.3 remote-as 300
no auto-summary
ip prefix-list BGP65 seq 5 permit 24.0.65.0/24
route-map SUPPRESS permit 10
match ip address prefix-list BGP65
Confirmation:
R2#sh ip bgp neighbor 1.1.23.3 advertised-routes
BGP table version is 11, local router ID is 24.0.67.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/24 0.0.0.0 0 32768 i
*> 24.0.64.0/22 0.0.0.0 32768 i
*> 24.0.66.0/24 0.0.0.0 0 32768 i
*> 24.0.67.0/24 0.0.0.0 0 32768 i
Total number of prefixes 4
R3:
R3#show ip bgp | begin Network
Network Next Hop Metric LocPrf Weight Path
*> 24.0.64.0/24 1.1.23.2 0 0 200 i
*> 24.0.64.0/22 1.1.23.2 0 0 200 i
*> 24.0.66.0/24 1.1.23.2 0 0 200 i
*> 24.0.67.0/24 1.1.23.2 0 0 200 i
Explanation:
Unlike most other routing protocols, BGP does not suppress more specific prefixes when summarizing. Using the "suppress-map" option in the aggregate-address command allows you to selectively suppress certain prefixes specified via a route-map. Alternatively, you can use the "summary-only" keyword to suppress all prefixes. As I will detail in my next post, you can use a combination of the "summary-only" option and the "unsuppress-map" on a neighbor statement to suppress all more specific prefixes and selectively permit some through to a certain neighbor.
DocCD items to reference:
show ip bgp neighbors [advertised-routes]
No comments:
Post a Comment