Tuesday, February 17, 2009

ALU - BGP Aggregation Part 3

Foreward: An ALU is an Autonomous Learning Unit, you can read this post to learn more about them.


 

 

Paste the following configuration into R4:

interface Loopback2564

 ip address 25.0.64.2 255.255.255.0

interface Loopback2565

 ip address 25.0.65.2 255.255.255.0

interface Loopback2566

 ip address 25.0.66.2 255.255.255.0

interface Loopback2567

 ip address 25.0.67.2 255.255.255.0

route-map BGPOUT

  set as prepend 25 60 70 

router bgp 400

  neighbor 1.1.124.2 remote 200

  neighbor 1.1.124.2 route-map BGPOUT out

  network  25.0.64.0 mask 255.255.255.0

  network  25.0.65.0 mask 255.255.255.0

  network  25.0.66.0 mask 255.255.255.0

  network  25.0.67.0 mask 255.255.255.0

 

R2 is in AS 200, R4 is in AS 400.  R2 and R4 should peer via their FastEthernet interfaces.  R4 is advertising a series of prefixes to R3, configure R3's "show ip bgp" below.  Use one, and only access-list; that access-list must have only one line.  Any future prefixes must be accepted, and not tagged with a local preference or weight.

 

R3#show ip bgp

   Network       Next Hop  Metric LocPrf Weight Path

*> 25.0.64.0/24  1.1.124.4      0         22222 400 25 60 70 i

*> 25.0.64.0/22  0.0.0.0            2323  32768 400 25 60 70 i

*> 25.0.65.0/24  1.1.124.4      0    222      0 400 25 60 70 i

*> 25.0.66.0/24  1.1.124.4      0         22222 400 25 60 70 i

*> 25.0.67.0/24  1.1.124.4      0    222      0 400 25 60 70 i

 

 

Proctor Question:

  CCIE Candidate: Mr. Proctor, do you consider a prefix-list an access-list for this question?

  Proctor: No.

 

 

 

Highlight below for the solution:

 

Solution:

router bgp 200

 aggregate-address 25.0.64.0 255.255.252.0 as-set attribute-map BGPAGG

 neighbor 1.1.124.4 remote-as 400

 neighbor 1.1.124.4 route-map BGPIN in

 neighbor 1.1.124.4 unsuppress-map UNSUPPRESS

 

ip prefix-list BGPEVEN seq 5 permit 25.0.64.0/24

ip prefix-list BGPEVEN seq 10 permit 25.0.66.0/24

access-list 2 permit 25.0.65.0 0.0.2.255

 

route-map BGPAGG permit 10

 set local-preference 2323

 

route-map BGPIN permit 10

 match ip address 2

 set local-preference 222

route-map BGPIN permit 20

 match ip address prefix-list BGPEVEN

 set weight 22222

route-map BGPIN permit 30

 

 

Explanation:

BGP has many attributes, and a CCIE candidate should be very comfortable with changing any attribute.  This question also requires keen attention to detail, because the output of "show ip bgp" contains a lot of information.  In this case, we can see some prefixes have a local preference set, some have a weight set, and the aggregate address has a different local preference set, and contains an AS PATH.

 

The other twist in this question is the statement that you need to use a single line access list to match some prefixes.  This requires an access-list that matches even or odd addresses.  The other BGP attribute should be set using a prefix list.  The final requirement was all future prefixes should not be modified, hence the "route-map BGPIN permit 30" statement.  These settings are combined into the route-map BGPIN and put on the neighbor statement.

 

Finally, by default, the aggregate-address will strip the BGP AS Path, so since the aggregated address in this "show ip bgp" output has a BGP AS path, we need to use the "as-set" option in the aggregate-address.

 

CCIE candidates should review this type of question several times, even putting your finger on every word, to verify they have met every requirement of this question.  A question like this will be verified by looking at the "show ip bgp" output, so there is no reason you should not receive all points.

 

DocCD items to reference:

Configuration Guide

aggregate-address

 

2 comments:

  1. Hey Eric,
    great stuff.
    I think you can leave the
    neighbor 1.1.124.4 unsuppress-map UNSUPPRESS

    part out though.
    Alef

    ReplyDelete
  2. Much appreciated such a great amount for this data. I need to tell you I agree on a few of the focuses you make here and others might require some further survey, however I can see your perspective. 192.168.1.254

    ReplyDelete